通达信10天没创新高

跪求高手 编写一个N日内 股价 不创新低 创新高 的选股公式。

这个不用编 一般交易软件自带的就有N日内 股价 创新高

通达信前几天高于今天10%以上的不选择?

这个可以编写,但你要说明前几天啊,编写公式要有具体条件啊。

通达信选股 10天之内没有未回补的跳空缺口 谢谢

AA:=L>REF(H,1);
QA:=IF(COUNT(AA,N)>0,BARSSINCEN(AA,N),DRAWNULL);{N时间范围}
AW:=REF(H,QA+1);
QW:=BARSLAST(H>=HHV(H,QA));
WL:=REF(L,QW);
XG1:=QW>0 AND REF(L,1)<=WL AND LLV(L,QA)>AW;
WW1:=L>REF(H,1);
WW2:=BARSLAST(WW1);
AA1:=LLV(L,WW2);
WW3:=AA1>REF(H,WW2+1) AND WW2>=1 AND WW2<N;
XG:=XG1 OR WW3;
TS:=CURRBARSCOUNT;
TS1:=BARSSINCE(C);
常数:=CONST(BARSSINCE(C));
C1:=REFX(C,常数-TS1*2+2);
C2:=REF(C,常数-TS*2+2);
O1:=REFX(O,常数-TS1*2+2);
O2:=REF(O,常数-TS*2+2);
H1:=REFX(H,常数-TS1*2+2);
H2:=REF(H,常数-TS*2+2);
L1:=REFX(L,常数-TS1*2+2);
L2:=REF(L,常数-TS*2+2);
CC:=IF(TS>TS1,C1,C2);
OO:=IF(TS>TS1,O1,O2);
LL:=IF(TS>TS1,L1,L2);
HH:=IF(TS>TS1,H1,H2);
返缺口:=HH<REF(LL,1);
信号:=返缺口 AND REF(LLV(LL,TS1),1)>HH;
返信号:=CROSS(SUM(信号,TS1)=1,0.5);
低价:=IF(返信号,REF(LLV(LL,TS1),1),0);
低价横线:=REF(低价,BARSLAST(返信号));
正信号:=REF(HH,BARSLAST(返信号))=H AND REF(LL,BARSLAST(返信号))=L AND
REF(CC,BARSLAST(返信号))=C AND REF(OO,BARSLAST(返信号))=O;
天天:=BARSLAST(正信号);
缺口上:=REF(低价横线,天天);
缺口下:=REF(H,天天);
XG:DYNAINFO(17)!=0 AND ((LLV(L,天天)>缺口下 AND 天天>=1 AND 天天<=10 ) OR XG);

通达信创历史新高的问题

HHV(H,5)=HHV(H,N);
这个是5日内创出N日历史新高的公式,5和N都可以调整。
股票公式专家团为你解答,希望能帮到你,祝投资顺利。

通达信选股公式的30天内20日线连续上升戓下跌的天数不能超过20天怎么写?谢谢

A:=COUNT(MA(C,20)>REF(MA(C,20),1),20)=20;
B:=COUNT(MA(C,20)<REF(MA(C,20),1),20)=20;
XG:COUNT(A,30)=0 AND COUNT(B,30)=0;
测试通过,
希望能够帮助你!

求通达信公式,统计30天内的最大成交量,但是如何将这30天内有复牌日当天及第二天的成交量剔除的公式?

是30天成交量的合计吗?如果是:

换手:=v/capital*100;

AA:=SUM(换手,30);

BB:=ABS(C-REF(C,1))/REF(C,1)>0.11;

CC:=EXIST(BB=1,30);

XG:IF(CC=1,0,AA);

一定不能勾选"前复权数据"。公式里面已经加了变向的判断函数,如果勾选就会绕过判断条件。